FreeBSD manual
download PDF document: devctl_notify.9.pdf
DEVCTL_NOTIFY(9) FreeBSD Kernel Developer's Manual DEVCTL_NOTIFY(9)
NAME
devctl_notify - Send a message, via devctl, to userland
SYNOPSIS
#include <sys/devctl.h>
void
devctl_notify(const char *system, const char *subsystem,
const char *type, const char *data);
DESCRIPTION
Send a notification to user land via devctl(4). See devctl(4) for the
format of these messages.
The devctl_notify function creates a string using the following template:
snprintf(buffer, sizeof(buffer), "!system=%s subsystem=%s type=%s",
system, subsystem, type);
The system, subsystem, and type pointers cannot be NULL.
The data argument may be NULL (for no additions) or a message formatted
properly for devctl(4). A space will be added to the above template and
this argument copied verbatim to form the message passed to userland.
Senders should balance between only passing data that userland can not
discover itself and sending all the data userland will want to use to
decide what to do with the message.
The current total message length limit is just under 1kb. Senders should
try to remain well below this limit.
SEE ALSO
devctl(4), devd(8)
AUTHORS
This manual page was written by M. Warner Losh
FreeBSD 14.0-RELEASE-p11 September 22, 2020 FreeBSD 14.0-RELEASE-p11